Switching configuration journal



Switching configuration journal

To create a vlan:

Switch(config)# vlan 2

Switch(config-vlan)# name Engineering

Switch(config-vlan)# vlan 101

Switch(config-vlan)# name Marketing

To assign a vlan to a port

Switch(config)# interface type module/number

Switch(config-if)# switchport

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan vlan-num

Setting a trunk

Switch(config)# interface type mod/port

Switch(config-if)# switchport

Switch(config-if)# switchport trunk encapsulation {isl | dot1q | negotiate}

Switch(config-if)# switchport trunk native vlan vlan-id

Switch(config-if)# switchport trunk allowed vlan {vlan-list | all |

{add | except | remove} vlan-list}

Switch(config-if)# switchport mode {trunk | dynamic {desirable | auto}}

Setting a vtp domain server/client/transparent

Switch(config)# vtp domain domain-name

Switch(config)# vtp mode {server | client | transparent}

Switch(config)# vtp password password

Switch(config)# vtp version {1 | 2}

VTP pruning

Switch(config)# vtp pruning

Switch(config)# interface type mod/num

Switch(config-if)# switchport trunk pruning vlan {add | except | none | remove} vlan-list

Spanning tree

Extended vlan

Switch(config)# spanning-tree extend system-id

Spanning tree priorty

Switch(config)# spanning-tree vlan 5,100-200 priority 4096

Set spanning tree macro for root or secondary and the diameter of the switching topology

Switch(config)# spanning-tree vlan vlan-id root {primary | secondary} [diameter

diameter]

setting a spanning tree port path cost ( per port basis)

Switch (config-if)# spanning-tree [vlan vlan-id] cost cost

Setting a spanning tree port priority ( per port basis)

Switch(config-if)# spanning-tree [vlan vlan-list] port-priority port-priority

Set portfast as default

Switch(config)# spanning-tree portfast default

Set port as portfast

Switch(conf-if)# spanning-tree portst

Setting a switch to use uplink fast

Switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]

Setting a switch for backbone fast

Switch(config)# spanning-tree backbonefast

Root Guard

Switch(config-if)# spanning-tree guard root

BPDU gurad default

Switch(config)# spanning-tree portfast bpduguard default

Bpdu guard interface

Switch(config-if)# [no] spanning-tree bpduguard enable

Loop guard default

Switch(config)# spanning-tree loopguard default

Loop guard interface

Switch(config-if)# [no] spanning-tree guard loop

UDLD default

Switch(config)# udld {enable | aggressive | message time seconds}

UDLD interface

Switch(config-if)# udld {enable | aggressive | disable

BPDU filter

Switch(config)# spanning-tree portfast bpdufilter default

BPDU filter interface

Switch(config-if)# spanning-tree bpdufilter {enable | disable}

RPVST enable

Switch(config)# spanning-tree mode rapid-pvst

Enable MST on the switch:

Switch(config)# spanning-tree mode mst

Enter the MST configuration mode:

Switch(config)# spanning-tree mst configuration

Assign a region configuration name (up to 32 characters):

Switch(config-mst)# name name

Assign a region configuration revision number (0 to 65,535):

Switch(config-mst)# revision version

Map a vlan to a mST instance

Switch(config-mst)# instance instance-id vlan vlan-list

................
................

In order to avoid copyright disputes, this page is only a partial summary.

Google Online Preview   Download